DegreeWorks Outage
Incident Report for Lanier Tech IT Status
Resolved
DegreeWorks service has been restored.
Posted Apr 20, 2023 - 08:34 EDT
Investigating
DegreeWorks is currently experiencing an issue. We have notified the appropriate support personnel at the system office and are awaiting a response. Additional info will be made available as received.
Posted Apr 20, 2023 - 08:17 EDT
This incident affected: College-wide Services (Degree Works).