Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2024 - 13:00 EDT
Scheduled
Due to Lanier Technical College's fiscal year end requirements, students will not have the ability to register or access BannerWeb/DegreeWorks during the last week of June 2024, 6/24/2024-6/30/2024. Thanks for your understanding and patience.
Posted Jun 25, 2024 - 12:29 EDT
This scheduled maintenance affected: College-wide Services (Banner, Degree Works).